MyFPGA Forum

 找回密码
 注册
搜索
热搜: 活动 交友 discuz
查看: 182|回复: 0

【FAQ】Quartus 版本升级编译出现问题

[复制链接]
发表于 2020-12-2 17:09:32 | 显示全部楼层 |阅读模式
本帖最后由 wyzhou 于 2020-12-2 17:27 编辑

Q: 同一个工程,为什么在Quartus II 15.1版本可以順利编译成功,但是,升级到新版本Quartus II 16.1.2编译后,出现如下图错误提示信息,是否有解决办法呢?
错误提示.png

A: 可以参考错误提示信息的内容对工程进行相关修改。如图所示,提示信息中提到hps_io_gpio_inst_GPIO00[0]引脚未连接。 请注意,对应引脚如果不需要在top 中进行连接,则不要在Qsys里面设定为GPIO。Qsys中删除对应信号hps_io_gpio_inst_GPIO00[0]即可。
出现这类错误是由于Quartus版本差异引起的。在新的版本中,Quartus有时会做更多的检查,更为严格。如遇报错,需按照提示信息做对应修改。

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|MyFPGA

GMT+8, 2021-1-19 20:35 , Processed in 0.063748 second(s), 19 queries .

Powered by Discuz! X3

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表