MyFPGA Forum

 找回密码
 注册
搜索
热搜: 活动 交友 discuz
查看: 243|回复: 0

【FAQ】DE1-SoC在Ubuntu系统 SoC EDS 20.1环境中交叉编译出错

[复制链接]
发表于 2020-11-27 11:30:39 | 显示全部楼层 |阅读模式
本帖最后由 wyzhou 于 2020-11-27 17:03 编辑

Q: DE1-SoC开发板,在 Ubuntu系统 SoC EDS 20.1环境中交叉编译my_first_hps-fpga 工程。
运行make命令报错 make: arm-linux-gnueabihf-gcc: command not found时,该如何解决呢?

A:20.1版本的SoC EDS + DS5沒有包含arm-linux-gnueabihf toolchain。
如果是ubuntu,可以使用指令:sudo apt install gcc-arm-linux-gnueabihf 进行编译链安装。
并注意编译前,执行命令:
~/intelFPGA/20.1/embedded/embedded_command_shell.sh
确认添加gcc 工具链后,编译是可以正常进行的。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|MyFPGA

GMT+8, 2021-1-19 20:37 , Processed in 0.062473 second(s), 16 queries .

Powered by Discuz! X3

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表